您好!欧宝体育竞猜

5.11-【万能MACD】多功能MACD幅图指标
栏目导航
当前位置:欧宝体育竞猜 > 欧宝首页 >
5.11-【万能MACD】多功能MACD幅图指标
浏览:180 发布日期:2021-05-30

友谊挑醒:

竖立安详营业模式是在股市永远生存的唯一途径,

指标则是协助竖立安详营业模式的一个有效工具。

迎接留言区交流

图片

图片

指标仅供学习参考钻研之用,不提出直接行为股票营业按照,能够结相符自己经验和大盘环境进走综相符判定,依此操作盈亏自夸。公式是物化的,人是活的。变通行使,仅供参考。【精品指标分享】指标效率图

图片

指标源码(幅图)

{万能MACD}

SQX:=(C-MA(CLOSE,13))*100;

DIF:EMA(MA(SQX,7),1),LINETHICK1;

DEA:EMA(DIF,7),LINETHICK1;

MACD: (DIF-DEA)*2,COLORSTICK;

红柱持股:IF(MACD>REF(MACD,1),MACD,DRAWNULL),STICK,COLORRED,LINETHICK3;

绿柱持币:IF(MACD<REF(MACD,1),MACD,DRAWNULL),STICK,COLORGREEN,LINETHICK3;

矮位金叉:IF(CROSS(DIF,DEA) AND DIF<-0.1,0.3,0),COLORYELLOW,POINTDOT;

STICKLINE(矮位金叉,0,10,8,1),COLORYELLOW;

DRAWICON(矮位金叉,0.3,1);

JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

DRAWTEXT_FIX(C>0,0,0,0,'公多号:【我喜欢指标】'),COLORMAGENTA;

二次金叉:IF(CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,0.2,0),COLORFF00FF,POINTDOT;

STICKLINE(二次金叉,25,15,8,欧宝首页1),COLORFF00FF;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA),0.1,0),COLORRED,POINTDOT;

STICKLINE(底背离,40,30,8,1),COLORMAGENTA;

DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORMAGENTA,LINETHICK3;

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

顶背离:REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF),COLORGREEN;

DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORBLUE,LINETHICK3;

A3:=CROSS(DIF,DEA) AND DEA<0;

零下二次金叉:IF(FILTER(COUNT(A3,21)=2,10),0.05,0),COLORWHITE,POINTDOT;

STICKLINE(零下二次金叉,45,55,8,1),COLORWHITE;

金叉:DRAWICON(CROSS(DIF,DEA),DIF,1);

物化叉:DRAWICON(CROSS(DEA,DIF),DIF,2);

{完}